Spanning Tree Troubleshooting

  • Identify the routing path of traffic 
    • Is there any HSRP
      • #show standby
    • Check VLANs
      • #show vlan brief
    • Which switch is the root switch and which ports are block ports
      • Check the spanning-tree details and find the root bridge
        • #show spanning-tree vlan [vlan#]
          • Summary and details of Root and Bridge ID and interface details
          • Verify all switches have matching spanning tree Root Bridge
          • Check Priority
  • Set switch as Span-tree Primary and Secondary
    • Primary
      • (config)#spanning-tree vlan [vlan#] root primary
      • (config)#spanning-tree vlan [vlan#] root secondary
  • Portfast and bpduguard is set on an interfaces or can be set at default for all access ports
    •  Interface
      • (config)#int [interface]
      • (config-if)#spanning-tree portfast
      • (config-if)#spanning-tree bpduguard enable
    • Default on all access ports
      • (config)# spanning-tree portfast bpduguard default

HSRP Configuration

  • Basic HSRP
    • Configure basic HSRP of the 10.10.10.0/24 network
      • R1(config-if)#standby ip 10.10.10.1
      • R2(config-if)#standby ip 10.10.10.1
        • I missed a priority  when entering the standby, so it automatically set the group to zero and the priority to 100
        • #no standby 0 ip 10.10.10.1 and replace it by “standby group# ip VIP-IP”
        • When I changed one router to use group 1 I got a constant stream of Duplicate address 
    • Check HSRP active router
      • #show standby brief
      • #show standby
    • What is physical MAC address
      • show int g0/1
    • What is HSRP virtual interface MAC address
      • #show standby
  • Priority and Pre-emption
    • Set router 1 has the preferred router
      • (config-if)standby 1 priority 110
Moving and studying do no go hand in hand, but I am in my new place and the network is about all setup.  It will be rough trying to get all the studying that I need in and the test taken before the end of the month, but I am going to keep focusing and time will tell.

 

 

DHCP Configureation Lab

  • Configure the interface to accept DHCP address
    • (config-if)#ip address dhcp
  • Verify interface received IP address
    • (config-if)#do show ip int brief
  • What is the IP address of the DHCP server
    • #show dhcp lease
  • Enable router to be a DHCP server
    • (config)#ip dhcp pool [Name of pool]
    • (dhcp-config)#network 10.10.10.0 255.255.255.0
    • (dhcp-config)#dns-server 10.10.10.1
    • (dhcp-config)#exit
    • (config)#ip dhcp excluded 10.10.10.1 10.10.10.10
      • Note: the lab demestrates that all the exceptions can be put in before setting up the pool.  So I should have excluded the  range to ensure that they could not be handed out after the pool is created.  Additionally the lab did not not specifically call for a gateway but it was put in during the lab.
    • (config)#ip dhcp pool [name of pool]
    • (dhcp-config)#default-routere 10.10.10.1
  • Show that clients received ip addresses
    • #show ip dhcp binding
    • BONUS: Since I did not put in the exclusion be for create the pool my clients go IP addresses in the “excluded range” and I had a conflict since the routers IP address is 10.10.10.1 which is also in the excluded range.
      • Clear DHCP conflicts
        • # clear ip dhcp conflict *
      • First client’s IP address was change on the client itself using the cmd promt
      • Second client’s IP address was release through the following command but this only releases it on the DHCP server but the client will have to have it renewed on the device itself.
        • #clear ip dhcp binding 10.10.10.3
          • This command was missing in Packet Tracer but found it on Cisco’s chat board.
  • Remove DHCP from router
    • (config)#no ip dhcp pool [pool name]
    • (config)#no ip dhcp 10.10.10.1 10.10.10.10
  • Configure DHCP relay/helper address on client network
    • (config)#int f0/0
    • (config-if)#ip helper-addresss 10.10.20.10

 

 

 

 

 

 

Lab 20 – OSPF Configuration

  • Enable a loopback interface on all routers.
    • (config)#int loopback0
    • (config-if)#ip address [ip address] 255.255.255.255
  • Enable single area OSPF, exclude interfaces on edge router
    • (config)#route ospf 100
    • (config-router)#passive-interface [interface] – For segments that should not get ospf advertisement.
    • (config-router)#network 10.0.0.0 0.255.255.255 area 1
    • (config-router)#network 192.168.0.0 0.0.0.255 area 1
      • I forgot to add the loopback route
  • Show OSPF id
    • (config)#show ip protocols
  • Show router adjacencies
    • (config)#show ip ospf neighbors
  • Show all loopbacks are in the routing table
    • (config)#show ip route
  • Set reference bandwidth so that a 100 Gbps interface will have a cost of 1
    • (config-router)#auto-cost reference-bandwidth 100000
      • Had to look up in my notes for command
  • Verify the cost of the fastEthernet links
    • (config)#show ip ospf interface [interface]
      • Another lookup.
  • Edit the cost on the interfaces 
    • (config-if)#ip ospf cost [cost]

So I have decided that I am going to move toward getting my next piece of paper (certification) and take a back seat to applying for positions.  Maybe something will come out of the ones that I have already applied for but as this is all items that I know and I just need to focus on how Cisco wants the answered so that I can ensure my future employers can confirm I know CCNA subject matter,  time to focus on CCNA.

 

 

Lab 19 – IGP Interior Gateway Protocol Fundamentals Configuration

  • Configure RIP on all routers
    • (config)#route rip
    • (config-router)#no auto
    • (config-router)#network 10.0.0.0
  • Verify routes
    • (config-router)#do show ip route
  • Add Internet route to RIP on router R4 and make interface f1/1 passive to make sure rip info is not passed.
    • (config-router)#passive-interface f1/1
    • (config-router)#network 203.0.113.0
  • Add default route on R4 using 203.0.113.2
    • (config)#ip route 0.0.0.0 0.0.0.0 203.0.113.2
  • Distribute default route over rip
    • (config)#route rip
    • (config-router)#default-information originate
      • So the first time I did it will out looking at the answer I put in “network 0.0.0.0” before the originate command.  When I verified the routes on the other routers the 0.0.0.0 did not appear until I added “network 0.0.0.0”, but decided it was best to reset the entire RIP routing with a “no route rip” to clear everything out.
  •  

 

 

 

 

Looking for a new position while studying is a true challenge.  The funny thing is there are positions that request the CCNA to be able to apply so finding the right balance of studying for the test and applying for jobs is very interesting.  At this point, I feel that I am ready to take the test but with the cost of the test, I really only want to take it once and reading online some of the posts make me nervous that I need to study more as some of the questions can be a bit tricky in the wording.

So the plan is to go through the labs that came with the Udemy study guide, do the labs that I have downloaded from Keith Baker’s website as well as go through his weekly CCNA quizzes and then take the test….

 

 

Lab 16 – Routing Fundamentals

  • Rename the router Hostnames
    • #conf t
    • (config)#hostname [name]
  • Assign IP address
    • #conf t
    • #int [interface]
    • ip address [IP address] [Subnet]
    • no shut
  • Verify Routes
    • #show ip route
      • It asks if I can see all the directly connected router switches and the question is supposed to “No I cannot”, and that is because it asked to just configure on the router and I did all routers so I can see all directly connected routes and not only the switches.
  • Should you be able to ping from PC1 to PC2?
    • Yes, the PCs are on networks that the router knows about, so traffic is passed successfully.
  • Should you be able to ping from PC1 to PC3?
    • No this is due to Router not knowing about networks other than the ones that are directly connected.
  • Configure IP address on R2, R3, and R4
    • Complete in the first step, actually before naming the routers.
  • Configure static routes on R1-R4 to allow connectivity between all subnets.
    • #conf t
    • (config)#ip address [IP range] [subnet] [gateway]
  • Remove all static routes from R1 and create on route for all 10.1.0.0 address
    • no ip address [IP Range] [Subnet] [gateway]
    • ip address 10.1.0.0 255.255.0.0 10.0.0.2
  • Default gateway
    • (config)# ip route 0.0.0.0 0.0.0.0 [gateway]

 

 

Lab 17 – Dynamic Routing Protocols – Using same network at Lab 16

  • RIP
    • Config RIPv1 on each router
      • #conf t
      • (config)#route rip
      • (config-router)#network [ip range]
      • (config-router)#no auto-summary
        • Requested in the lab notes.
    • Debug RIP on R1
      • debug ip rip
    • What type of traffic is being sent (unicast, broadcast or multicast)
      • Broadcast 255.255.255.255
    • Enter the commands to enable RIPv2 on all routers
      • #conf t
      • (config)# route rip
      • (config-router)#version 2
    • What type of traffic is being sent (unicast, broadcast or multicast) with version 2
      • Multicast
        • RIP: sending v2 update to 224.0.0.9 via [interface] ([IP address])
    • Turn off debugging
      • #no debug all
    • Check RIP routes
      • #show ip route
  • OSPF
    • Turn on OSPF on all routers
      • (config)#route ospf [ID]
      • (config-router)#network [IP Range] [reverse subnet] area [area ID]
    • Verify Routes
      • (config-router)#do show ip route
    • Disable R2 interface, what will happen to routes on R1
      • All routes are moved to 10.0.3.2 gateway since R2 is down.
      • Also the metrics are higher on the routes now due to the higher cost calculated by OSPF
  • Routing Protocol Metric and Administrative Distance
    • Remove OSPF from all routers
      • (config-router)# no network 10.0.0.0 0.255.255.255 area 0
        • Was what I put in but it should be
          • no router ospf 1
    • Will R1 still be able to get to R4
      • Yes RIP is still enabled
    • Enable EIGRP on all routers
      • (config)#route eigrp [eigrp group id]
      • (config-router)#no auto
      • (config-router)#network 10.0.0.0 0.255.255.255
  • Loopback interface
      • (config)#int loopback 1
      • (config-int)#ip address [ip address] [subnet/32]
      • (config-int)#no shut
    • Add Loopback to routing table
      • (config-router)# network 192.168.0.0 0.0.0.255
  • Adjacencies and Passive Interfaces
    • Show eigrp neighbors
      • #show ip eigrp neighbors
    • Set loopback and interface to a passive interface
      • (config)#route eigrp [eigrp group ID]
      • (config-router)#passive-interface [loopback interface]
      • (config-router)#passive-interface f1/1

 

 

 

 

If you are looking for some pop quiz, check out the quiz and come back and look at my learning notes from the quiz.

  • TCP/IP Layer “4” 
    • Question 1 – What L4 protocol does DHCP User
      • UDP – Correct – The client does not have an IP address so it has to rely on UDP, it uses DHCP to obtain an IP address.
      • Unicast – Incorrect – DHCP relies on a send and response, Unicast is a transmission from source to destination.
      • TCP – Incorrect – The client does not have an IP address.
      • Broadcast – Incorrect – While the client does broadcast to find the DHCP server the communication is directly between client and server.
    • Question 2 – What are used in a TCP 3-way Handshake? (Choose 2)
      • 2 Acknowledgements – Correct
      • 1 Acknowledgement
      • 2 Synchronization Requests – Correct
      • 1 Synchronization Requests
        • ANSWER: The 3-way handshake is base on the requesting client sending SYN packet (1st Sync request) telling the server how fast the client can communicate. The server/receiving device responds with an SYN/ACK packet (2nd Sync request/1st Acknowledgement).  This acknowledges that the server received the Sync requested but also how fast the communications will occur. Finally, the client sends an ACK packet acknowledging receipt of the SYN/ACK and the speed of communication.
        • Chris GreerHow TCP Works – The Handshake
    • Question 3 – Who’s L4 protocol is being used in this packet?
       

      • UDP – Incorrect – Protocol Number 17 – User Datagram Protocol – 
      • IPsec – CORRECT – protocol Number 50 – Encapsulating Security Payload.
        • IPsec is the only one that uses encapsulation.
      • TCP – Incorrect – Protocol Number 6 – Transmission Control Protocol
      • RDP – Incorrect – protocol Number 27 – Reliable Data Protocol
    • Question 4 – Which of the following are true regarding L4? (Choose 2)
      • OSPF uses TCP – Incorrect – Open Shortest Path First uses its own protocol (Protocol number 89)
      • BGP Uses TCP – CORRECT
      • RIP uses UDP – CORRECT
      • EIGRP UDP – – Incorrect – Enhanced Interior Gateway Routing Protocol uses its own protocol (Protocol number 88)
    • Question 5 – What L4 protocol is primarily used by IPv6 NDP (neighbor discovery protocol)?
      • SLAAC – Incorrect – Stateless address autoconfiguration – Hosts configure themselves automatically.
      • UDP – Incorrect – IPv6 avoids broadcasts and uses multi-cast instead
      • ICMP – CORRECT – NDP is a node discovery protocol in IPv6 which replaces and enhances functions of ARP.
      • TCP – Incorrect – Not used.
    • Question 6 – Which of the following are true regarding Telnet and SSH @ L4?
      • Telnet users TCP:23 – Connection is not stateless so it requires TCP
      • Telnet uses UDP:23 – Connection is not stateless so it requires TCP
      • SSH uses UDP:22 – Connection is not stateless so it requires TCP
      • SSH uses TCP:22 – Connection is not stateless so it requires TCP
    • Question 7 – NTP traffic is going over an EtherChannel L2 Trunk. What is true?
      • L4 protocol is TCP – Incorrect – While it can be used on different protocols the default protocol is UDP.
      • L4 protocol is UDP – CORRECT – While it can be used on different protocols the default protocol is UDP.
      • L4 protocol is PAgP – Incorrect – Port Aggregation Protocol is used to automate local aggregation of Ethernet switch ports and does not change how NTP communicates.
      • L4 protocol LACP – Incorrect – Link aggregation Control Protocol is for using multiple interfaces as one and does not affect NTP
    • Question 8 – From this request, what would the server response include?
       

      • Source port TCP 34622 – This is the port that the client requested traffic on.  The client is waiting for a response to this port.
      • Destination port TCP 80 – This is the port the client sent the traffic on and is would not be able to receive traffic on this port
      • Source port TCP 80 – CORRECT – The server reverses the port and sends the response traffic to the port that it received it from.
      • Destination port TCP 34622 – CORRECT – The server reverses the ports and sends out response traffic on the port it received the request on. The client has an established session on this port, waiting for the server to respond on this port
        • Answer: 
    • Question 9 – Who’s L4 protocol is being used in this packet?

      • OSPF – CORRECT – OSPF uses protocol 89 and Multi-cast
      • BGP – Incorrect – Uses TCP and does not use Multi-cast
      • EIGRP – Incorrect – Uses protocol 88 and does not use Multi-cast
      • RIP – Incorrect – Uses UDP and does not use Multi-cast
        • Answer:
    • Question 10 – Which of the following are true regarding FTP/TFTP @ L4? (Multiple Select)
      • FTP uses UDP – Incorrect – File Transfer Protocol is a stateful connection
      • TFTP uses UDP – CORRECT – Trivial File Transfer Protocol is a stateless connection
      • TFTP uses TCP – Incorrect – Trivial File Transfer Protocol is a stateless connection
      • FTP uses TCP – CORRECT – File Transfer Protocol is a stateful connection
    • Question 11 – Comparing TCP to UDP, which is true?
      • TCP has more overhead – CORRECT – Transmission Control Protocol has a handshake and error checking which creates more overhead than UDP that does not have either.
      • UDP is not reliable – CORRECT – With no error checking or handshake, UDP is considered not reliable.
      • TCP has less overhead – Incorrect – Transmission Control Protocol has a handshake and error checking which creates more overhead than UDP that does not have either.
      • UDP is reliable – Incorrect – – With no error checking or handshake, UDP is considered not reliable.
    • Question 12 – what is true regarding RADIUS vs TACACAS+? (Mulitple Select)
      • TACACS+ uses TCP – CORRECT – Uses Transmission Control Protocol to communicate with the Auth Server
      • TACACS+ uses UDP – Incorrect – Uses Transmission Control Protocol to communicate with the Auth Server
      • RADIUS uses UDP – CORRECT – Uses User Data Protocol to communicate with the Auth Server
      • RADIUS uses TCP – Incorrect – Uses User Data Protocol to communicate with the Auth Server